1. For downloading SimTools plugins you need a Download Package. Get it with virtual coins that you receive for forum activity or Buy Download Package - We have a zero Spam tolerance so read our forum rules first.

    Buy Now a Download Plan!
  2. Do not try to cheat our system and do not post an unnecessary amount of useless posts only to earn credits here. We have a zero spam tolerance policy and this will cause a ban of your user account. Otherwise we wish you a pleasant stay here! Read the forum rules
  3. We have a few rules which you need to read and accept before posting anything here! Following these rules will keep the forum clean and your stay pleasant. Do not follow these rules can lead to permanent exclusion from this website: Read the forum rules.
    Are you a company? Read our company rules

Simtools To Arduino Serial Monitor

Discussion in 'SimTools DIY Version' started by mjgutie2, Oct 15, 2016.

  1. mjgutie2

    mjgutie2 New Member

    Joined:
    Oct 14, 2016
    Messages:
    17
    Location:
    California
    Balance:
    141Coins
    Ratings:
    +5 / 0 / -0
    Hello, I'm new to this forum and trying to learn how to connect SimTools to the Serial Monitor of my Arduino Uno. I followed the guide here: https://www.xsimulator.net/community/marketplace/communicating-with-an-arduino-and-sim-tools.97/ , and commented out the Debug line but keep running into a problem.

    First I start the Axis Testing in Simtools, then when I try to open the Serial Monitor it doesn't allow it because "Error opening serial port 'COM4'. (Port busy)".

    If I open the serial monitor first, then turn on axis testing, the slide controls don't do anything in the monitor.

    Any help would be greatly appreciated.

    Thank you
  2. Ads Master

    Ads Master

    Balance:
    Coins
    Ratings:
    +0 / 0 / -0
  3. noorbeast

    noorbeast VR Tassie Devil Staff Member Moderator Race Director

    Joined:
    Jul 13, 2014
    Messages:
    14,950
    Occupation:
    Innovative tech specialist for NGOs
    Location:
    St Helens, Tasmania, Australia
    Balance:
    110,412Coins
    Ratings:
    +8,945 / 43 / -2
    My Motion Simulator:
    3DOF, DC motor, JRK
    Is anything running that is tying up port 4 and have you tried rebooting?
  4. mjgutie2

    mjgutie2 New Member

    Joined:
    Oct 14, 2016
    Messages:
    17
    Location:
    California
    Balance:
    141Coins
    Ratings:
    +5 / 0 / -0
    After looking at the code, I realized my mistake. The code only uses the serial monitor to test if the code is working and doesn't use the monitor with simtools.