1. For downloading SimTools plugins you need a Download Package. Get it with virtual coins that you receive for forum activity or Buy Download Package - We have a zero Spam tolerance so read our forum rules first.

    Buy Download Package Now!
  2. Do not try to cheat our system and do not post an unnecessary amount of useless posts only to earn credits here. We have a zero spam tolerance policy and this will cause a ban of your user account. Otherwise we wish you a pleasant stay here! Read the forum rules
  3. We have a few rules which you need to read and accept before posting anything here! Following these rules will keep the forum clean and your stay pleasant here. Do not following these rules will lead to permanent exclusion from this website: Read the forum rules.

Question Output testing USB COM port issue?

Discussion in 'SimTools DIY Version' started by optical10, Sep 14, 2018 at 20:34.

  1. optical10

    optical10 New Member

    Joined:
    Aug 20, 2018
    Messages:
    23
    Balance:
    212Coins
    Ratings:
    +2 / 0 / -0
    My Motion Simulator:
    6DOF
    I've just recently took delivery of a DOF reality P3 motion simulator but I'm having issues regarding lack of motion due to communication over the com port that requires game engine, control box and sometimes the pc needing to be restarted .
    When I speak to the supplier they say they can't help me with USB issues which seems fair (If that is in fact the issue) but as it's a USB 2.0 connected controller box and I'm struggling to find a stable USB 3.0/2.0 are USB port I thought I'd ask on this forum to see if there was any recommended solutions to solve this problem?
    On the single USB 2.0 expansion card I was able to run dirt Rally, fanatec club sport v2.5 wheel and v3 pedals and the P3 but as soon as I tried to run it with the Samsung VR headset as well I lost motion.
    Having spent the next day rearranging all the USB devices I was able to run dirt Rally with the VR headset and the fanatec wheel only if I turn the wheel on after being in the options menu after the game was running. I have made progress now that I have rearranged most of the higher powered devices to run off the motherboard USB 3.0 connectors and the Samsung VR headset off a an external USB 3.0 hub which allowed me to run F1 2017 straight after the rally without having to shut down the control box, game engine or the PC.
    Googling this issue doesn't seem to bring up a lot of results meaning that if DOF are correct and it's issue and they can't help me with why isn't there more people with this issue in these forums or am i I just unlucky with particular motherboard or power supply not been as properly earthed if that is in fact the cause as they suggested may be a possible solution?

    Any help much appreciated as I need to hone in on this before I run out of the return period if this is a hardware issue.
  2. yobuddy

    yobuddy Well-Known Member Staff Member Moderator SimTools Developer SimAxe Beta Tester Gold Contributor SimTools 2.0 Beta Tester

    Joined:
    Feb 9, 2007
    Messages:
    2,808
    Occupation:
    Computer Technician
    Location:
    Portland, Oregon - USA
    Balance:
    30,288Coins
    Ratings:
    +2,948 / 8 / -0
    Are you using any USB hubs?
  3. SeatTime

    SeatTime Well-Known Member SimTools 2.0 Beta Tester

    Joined:
    Dec 27, 2013
    Messages:
    1,927
    Location:
    Newcastle Australia
    Balance:
    24,580Coins
    Ratings:
    +2,270 / 20 / -0
    My Motion Simulator:
    DC motor, Motion platform, 6DOF
    Unfortunately not all motherboards are not created equal. From my own experience it can be a real game to sort ports out - especially when you add allot of peripherals. For a test, you could try lowering (increasing the number) the output rate on the simtools interface settings in Game Engine to 10msec and see if that helps.
    • Agree Agree x 1