1. For downloading SimTools plugins you need a Download Package. Get it with virtual coins that you receive for forum activity or Buy Download Package - We have a zero Spam tolerance so read our forum rules first.

    Buy Download Package Now!
  2. Do not try to cheat our system and do not post an unnecessary amount of useless posts only to earn credits here. We have a zero spam tolerance policy and this will cause a ban of your user account. Otherwise we wish you a pleasant stay here! Read the forum rules
  3. We have a few rules which you need to read and accept before posting anything here! Following these rules will keep the forum clean and your stay pleasant here. Do not following these rules will lead to permanent exclusion from this website: Read the forum rules.

Question 2DOF+Arduino R3+ Sabertooth 2x32 First Start Up Issues

Discussion in 'DIY Motion Simulator Building Q&A / FAQ' started by FoxHound.92, Oct 21, 2018.

  1. FoxHound.92

    FoxHound.92 2DOF seat mover

    Joined:
    Jan 11, 2018
    Messages:
    54
    Location:
    Germany
    Balance:
    158Coins
    Ratings:
    +19 / 0 / -0
    My Motion Simulator:
    2DOF, DC motor, Arduino
    Well as I was about to post that de- and reinstalling has not been effective I thought I better try overall functionality again in SMC3.

    I now get this rattling when testing with any active profile when the motor has to lift the platform:


    Very disappointing together with the fact that I can't work on solving my issues constantly :(
  2. FoxHound.92

    FoxHound.92 2DOF seat mover

    Joined:
    Jan 11, 2018
    Messages:
    54
    Location:
    Germany
    Balance:
    158Coins
    Ratings:
    +19 / 0 / -0
    My Motion Simulator:
    2DOF, DC motor, Arduino
    The main problem is that I'm not sure where to look for it.

    For my understanding it may be caused by the potentiometers.

    I used Arduino jumper wires to connect them. I used two jumper wires in combination to have the right length.
    Can this maybe a weak point?
  3. FoxHound.92

    FoxHound.92 2DOF seat mover

    Joined:
    Jan 11, 2018
    Messages:
    54
    Location:
    Germany
    Balance:
    158Coins
    Ratings:
    +19 / 0 / -0
    My Motion Simulator:
    2DOF, DC motor, Arduino

    I'm glad to reply that I am one step further:

    Now the communication finally works after setting firewall and antivirus exeptions everywhere I could.
    Output testing works as well.
    Both are working great within SMC3 now, I tweaked the parameters until I got smooth motion (so far).

    I got rid of the wiggling by reducing the Kp value down to 100.
    One major problem for me was I misunderstood the SMC3-tool. I thought it was only for testing, not for setting the parameters as well.
    So at first I tried to use SimTools with PWMmax = 0. So it is no wonder it did not move, right? :blush