1. You must be a registered member to be able to access this page and to download game plugins. Please register here. It´s for free.
  2. For downloading SimTools plugins you need a Download Package. Get it with virtual coins that you receive for forum activity or Buy Download Package - We have a zero Spam tolerance so read our forum rules first.

    Buy Now a Download Plan!
  3. Do not try to cheat our system and do not post an unnecessary amount of useless posts only to earn credits here. We have a zero spam tolerance policy and this will cause a ban of your user account. Otherwise we wish you a pleasant stay here! Read the forum rules
  4. We have a few rules which you need to read and accept before posting anything here! Following these rules will keep the forum clean and your stay pleasant. Do not follow these rules can lead to permanent exclusion from this website: Read the forum rules.
    Are you a company? Read our company rules
value1

NoLimits Rollercoaster Simulation Plugin 2.0.1.17

SimTools game plugin for NoLimits Rollercoaster Simulation

  1. Update for NLS V2.0.8.1

    value1
    Works fine with all different versions of NoLimits 2 Roller Coaster Simulator including the Steam versions and the demo versions, x86 and x64
  2. Support of NLS V2.0.8.0

    value1
    Supports now also V2.0.8.0 in demo and full mode.
  3. Update for NLS 2.0.7.4

    value1
    This plugin supports NLS V1.8 up to the latest NLS V2.0.7.4, both 32 and 64 bit versions.
  4. Update for NLS 2.0.7.0 and 2.0.7.1

    value1
    yawning.gif
  5. Update for NLS 2.0.6.0

    value1
    SweatSmiley.gif
  6. Update for NLS 2.0.5.2 Demo

    value1
    Supports all full versions from NLS 1.8-2.0.5.2 and all full versions of NLS2 up to 2.0.5.2
  7. Update to include version NLS 2.0.5.0, NLS 2.0.5.1 and NLS 2.0.5.2

    value1
    Additional to all the previous versions of NLS, this plugin also supports NLS 2.0.5.0, NLS 2.0.5.1 and NLS 2.0.5.2
  8. Update to include support for NoLimitsRollercoaster 2.0.4.2

    value1
    This update supports all versions up to NLS V2.0.4.2
  9. Update for NLS 2.0.4.0

    value1
    The plugin now also supports the NoLimitsRollercoasterSimulator 2.0.4.0
    (full version x86 and x64)
  10. Updated for NLS 2.0.3.0

    value1
    This plugin is also compatible now with No Limits Rollercoaster Simulator 2.0.3.0, 32bit and 64bit versions.